php 5.4 sous debian 8 ( jessie )

Parfois on a le besoin de rester sous d’ancienne version de php, sans pour autant ne pas profiter d’une version plus récente de debian donc : 1- Ajout des clé suivantes : wget dotdeb.org/dotdeb.gpg apt-key add dotdeb.gpg 2- Ajout dans sources.list : deb http://dotdeb.infogerance-linux.fr/ wheezy all deb http://debian.infogerance-linux.fr wheezy main 3- Création du fichier php54.pref Read more about php 5.4 sous debian 8 ( jessie )[…]

Gearman sur Scaleway

Bon ayant besoin de la dernière version de la lib gearman, sous armhf ( en clair plus récent que la 0.33 ), j’ai du installer depuis les sources celle ci . Voici déja la liste des paquets à installer pour répondre aux dépendances : apt-get install gperf libevent-dev uuid-dev libcloog-ppl-dev libboost-all-dev ensuite, il faut dl, Read more about Gearman sur Scaleway[…]

php 5.2.17 en php-fpm

Sous linux debian 7 64bits aptitude install patch make gcc libxml2-dev pkg-config libssl-dev libcurl3-dev libjpeg-dev libpng-dev libc-client-dev libmcrypt-dev libmhash-dev libmysql++-dev libxslt-dev libltdl7-dev wget http://museum.php.net/php5/php-5.2.17.tar.bz2 wget http://php-fpm.org/downloads/php-5.2.17-fpm-0.5.14.diff.gz https://bugs.php.net/patch-display.php?bug_id=54736&patch=debian_patches_disable_SSLv2_for_openssl_1_0_0.patch&revision=1305414559&download=1 patch php-${version}/ext/openssl/xp_ssl.c debian_patches_disable_SSLv2_for_openssl_1_0_0.patch.patch.txt ln -sf /usr/lib/libc-client.a /usr/lib/x86_64-linux-gnu/ ln -sf /usr/lib/libc-client.so /usr/lib/x86_64-linux-gnu/ tar -xvzf php-5.2.17.tar.bz2 gzip -cd php-5.2.17-fpm-0.5.14.diff.gz | patch -d php-5.2.17 -p1 cd php-5.2.17 ./configure –with-libdir=lib/x86_64-linux-gnu –enable-fastcgi –enable-fpm Read more about php 5.2.17 en php-fpm[…]

Ovh, kimsufi, suite de mes aventures

à titre d’infos, voici la suite des évènements que j’ai décris dans cet article, J’ai obtenu en insistant avec la hotline ( sur un ticket ouvert chez OVH, concernant mon kimsufi … ) un avoir . Pour ce faire, j’ai du demander 3 fois les coordonnées de leur médiateur . Au final, on m’indique 15 Read more about Ovh, kimsufi, suite de mes aventures[…]

OVH et ses Kimsufi, on marche sur la tête …

Petite anecdote , J’avais comme beaucoup de geek, loué il y a un an un kimsufi, chez OVH, une gamme conçue de toute pièce pour contrer les serveurs de Online . L’idée était de relouer des serveurs en fin de vie en gamme pro, à bas coup pour leur donner une seconde vie . Pourquoi Read more about OVH et ses Kimsufi, on marche sur la tête …[…]

Self signed certificate, fast and easy | my repository

Use certtool instead of openssl. It is less flexible but much more user friendly.1. Installation:Certtool is part of GnuTLS. On debian-based distributions you have to install the gnutls-bin package.2. Create a private key:# certtool -p –outfile server.key.pem3. Generate the self signed certificate:# certtool -s –load-privkey server.key.pem –outfile server.crt.pemYou will get a prompt to enter various Read more about Self signed certificate, fast and easy | my repository[…]

apt-mirror et translation i18

Il faut modifier /usr/bin/apt-mirror pour gérer les translations ligne 355 pour wheezy ligne 363 pour squeeze il vous faut trouver ces lignes de codes foreach (@components) { add_url_to_download($url . $_ . « /binary- » . $arch . « /Release »); add_url_to_download($url . $_ . « /binary- » . $arch . « /Packages.gz »); add_url_to_download($url . $_ . « /binary- » . $arch . « /Packages.bz2 »); et Read more about apt-mirror et translation i18[…]

HowTo/PostfixAndDovecotSASL – Dovecot Wiki

HowTo/PostfixAndDovecotSASL – Dovecot Wiki. Postfix and Dovecot SASL Since version 2.3, Postfix supports SMTP AUTH through Dovecot SASL as introduced in the Dovecot 1.0 series. If using Postfix obtained from a binary (such as a .rpm or .deb file), you can check if Postfix was compiled with support for Dovecot SASL by running the command: Read more about HowTo/PostfixAndDovecotSASL – Dovecot Wiki[…]